Sophos Notification - Upcoming Central Maintenance Release

Scheduled in progress (65 days 22 hours 35 minutes)
May 23, 12:03pm

Sophos Notification - Upcoming Central Maintenance Release

Status: in progress
Start: March 19, 1:00pm
Affected Components:
United States - DB Ireland - DB Germany - DB United States - DB Ireland - DB Germany - DB Central - Admin Dashboard Central - Enterprise Dashboard Central - Admin Dashboard Central - Enterprise Dashboard
Update

March 19, 1:00pm

March 19, 1:00pm

Sophos Notification: Upcoming maintenance release for Sophos Central, please check: https://soph.so/eZBlUC Unsubscribe at https://sophoscentral.status.page

Update

May 23, 12:02pm

May 23, 12:02pm

Sophos Notification: Important information about Sophos Central, please check: https://soph.so/mb8ZVi Unsubscribe at https://sophoscentral.status.page

Update

May 23, 12:03pm

May 23, 12:03pm

Some users have reported problems login into Sophos Central using Microsoft Sign-in. Our engineering team is working to restore service as quickly as possible. https://soph.so/mb8ZVi